0%

JS Node Sass 的一些错误及解决方式

老项目用的 node-sass 版本比较低,要么降级 node 版本,要么更新依赖,我选择了更新依赖,这是期间碰到的问题及解决方案

Node Sass 升级

目前是直接升级依赖如下

1
2
"sass": "^1.52.3",
"sass-loader": "^10",

或者

1
2
"sass": "^1.52.3",
"sass-loader": "7.3.1",

SassError: expected selector 报错 ::v-deep 替换 /deep/

搜了一下:尝试用 ::v-deep 替换 /deep/ ,成功解决了问题。

某些预处理器(例如 Sass)可能无法>>>正确解析。

TypeError: token.type.endsWith is not a function vue eslint 问题解决

直接把 babel-eslint 降级, 写死为 ^8.2.2

更改前: “babel-eslint”: “^10.1.0”,

更改后: “babel-eslint”: “^8.2.2”,

删除 node_modules

yarn install

参考文章